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For those of you who have inadvertently been sent a Microsoft Word document in the new .docx (x
for xml) format and can’t open it in your older version of Microsoft Word, this N.Y. Times Personal 
Tech article
has the explanation and some alternatives.

Why can't I open .docx files?

http://www.nytimes.com/2008/02/07/technology/personaltech/07askk-001.html?_r=1&8cir&emc=cir&oref=slogin
http://www.nytimes.com/2008/02/07/technology/personaltech/07askk-001.html?_r=1&8cir&emc=cir&oref=slogin


If you’re interested in changing the behavior or just outright disabling Microsoft Office Desktop
Alerts, like that “new mail” alert for Outlook that pops up out of the taskbar, here’s how:

https://support.office.com/en-us/article/Turn-new-message-alert-pop-up-on-or-off-9940c70e-b306-
442e-a856-d94b20318481

(dead link – http://office.microsoft.com/en-us/assistance/HP010416051033.aspx)

How do I disable Microsoft
Office Desktop Alerts?

https://support.office.com/en-us/article/Turn-new-message-alert-pop-up-on-or-off-9940c70e-b306-442e-a856-d94b20318481
https://support.office.com/en-us/article/Turn-new-message-alert-pop-up-on-or-off-9940c70e-b306-442e-a856-d94b20318481
http://office.microsoft.com/en-us/assistance/HP010416051033.aspx


If you have MS Word 2000 or higher, you’ll be able to open WordPerfect files and if the document
was created with WordPerfect 6.0 or later.

To do this, open a blank document in MS Word. Go to the Tools menu and click on Options. Select
the General tab and check mark the box that reads “Confirm Conversion at Open.” Then click OK.
Open the WordPerfect files and a box will prompt you to choose the conversion. Select
WordPerfect 6.×.

Here’s the reference link from Microsoft Tech Support:

http://support.microsoft.com/?kbid=211692

I haven’t tested it, but this site http://www.zamzar.com/ claims to be able to convert WordPerfect
to Microsoft Word format.

How can you open
documents created in
WordPerfect with MS Word?

http://support.microsoft.com/?kbid=211692
http://www.zamzar.com/


If you are experiencing problems with clients connecting to the campus KMS servers and you have
confirmed that your DNS has been setup properly, you can manually force activation of a license.

HSSEAS has posted instructions.

Windows 7/Office 2010
License Activation Issues

http://www.seasnet.ucla.edu/software/software-download/frequently-asked-questions/mcca-licenses


The Microsoft Home Use Program allows employees at eligible companies to buy an annual
subscription of Microsoft 365 Family or Microsoft 365 Personal at a discount for use on personal
devices.

https://www.microsoft.com/en-us/home-use-program

Microsoft Office Home Use
Program

https://www.microsoft.com/en-us/home-use-program


You can turn on certain tools in Excel such as data analysis tools or equation solving tools from
Excel itself.

Once Excel has been installed completely:
Navigate to TOOLs and then Add Ins.

You can check the box next to each free tool offered by Excel for free.

How do I enable special add-
in and tools in Excel?



How to Use INDEX+MATCH With
Multiple Criteria in 5 Easy Steps (includes Excel 2016)
How To Use Index/Match, The One Microsoft Excel Trick That Separates The Gurus From The 
Interns
The First 8 Excel Tricks You Have To Learn On The Way To Becoming A Master

Excel Tricks

http://spreadsheeto.com/index-match/
http://www.businessinsider.com/excel-index-match-2013-7
http://www.businessinsider.com/excel-index-match-2013-7
http://www.businessinsider.com/excel-countif-sum-functions-if-sumproduct-dollar-sign-2013-7


This link explains the process: Tech-Recipes (Warning: has ads)

Note: To select multiple files click the first file, and then shift click the last file and all consecutive
files will be highlighted. To selected individual files ctrl click the desired files.

The following advice was found on that page:

Word makes it easy to print several files at once. The user does not even need to open them first.

(This sends the files straight to the printer without allowing you to adjust your printer settings.)

1. Click the File Menu
2. Select Open
3. After the open window displays, select the files you wish to print.
4. Right click on one of the selected files to open the context menu
5. Left click Print from the context menu.

This is perfect when your boss wants last month’s reports printed NOW!

How to Print Multiple files in
MS Word

http://www.tech-recipes.com/microsoft_word_tips346.html


Does anyone know if there is a campus group that provides assistance with setting up a database
in Access or who can answer questions? Lynda and Google have been my friends, but now I need
human help. :-)

Help with Microsoft Office
Applications



Microsoft Powerpoint supports notes with each slide, yet the default slideshow view on most
Powerpoint installations is a standard slideshow only, which hides the notes from the presenter.

The Mac versions seem to be the notable exception in that more of them default to “Presenter”
mode for slideshows, which shows the Powerpoint slides only on the external display and the
slides w/timer, forward/back filmstrip of slides, and the slide notes on the computer display.

To enable this in Microsoft Office 2003’s Powerpoint:
http://office.microsoft.com/en-us/powerpoint/HA010565471033.aspx

Ensure the projector is connected first and active, and set to clone the display.

1. In PowerPoint, on the Slide Show menu, click Set Up Show.
2. Under Multiple monitors, select the Show Presenter View check box.
3. In the Display slide show on list, click the monitor you want the slide show presentation to

appear on.

To enable this in Microsoft Office 2007’s Powerpoint, it is almost identical:
http://office.microsoft.com/en-us/powerpoint/HA100673831033.aspx

Enabling Presenter mode in
Powerpoint

http://office.microsoft.com/en-us/powerpoint/HA010565471033.aspx
http://office.microsoft.com/en-us/powerpoint/HA100673831033.aspx


To create a poster in PowerPoint, design one “slide” with its page size set to the size of your
poster. Any color scheme that offers good contrast between foreground and background is
acceptable, although you may find that white or light colored backgrounds with dark text work
best.

1. From the File menu go to:

New Presentation: Choose a Blank slide layout
Page Setup: Select “Custom” from the “Slides sized for:” drop-down box and enter values
for page Width and Height. If your desired poster size is less than 56 inches in its longest
dimension, enter the actual final dimensions. If your desired poster size is 56 inches or
greater in its longest dimension, enter Width and Height values at one-half final size. Then
scale your file at the printer to achieve the final poster dimensions. For example, if your
desired final size is 48 inches by 72 inches, set your PowerPoint page to 24 inches by 36
inches.

2. To add text:

New text – Select PowerPoint’s Text Box tool and type in your text
Existing text – From Microsoft Word, “Copy” and “Paste Special as Unformatted Text” into
your PowerPoint document. Then apply text formatting as needed.
When adjusting horizontal positioning of text strings, always use tabs or justification buttons.
Using spaces can cause text alignment problems because the size of a space is not
consistent from system to system.
If your file uses any unusual fonts, you may need to supply the font files in order to correctly
print the poster.

3. To add tables or graphs:

How to Create a Poster in
PowerPoint



To insert tables or graphs from Microsoft Word or Excel, select the Insert menu, point to 
Insert:Object, and click on the appropriate application. Alternatively, you can “Copy” the
table or graph to the clipboard and “Paste Special as Picture”.
Tables can be easily constructed within PowerPoint using tabs. The program includes left,
right, center, and decimal justification tabs on the text ruler.
For graphic objects from non-Microsoft Office applications use Save As or Export to create
an EPS file from that application. You can then insert the file into your PowerPoint document.
On the Insert menu point to Insert:Picture and click on From File…

4. To add scanned images:

Scanned images should have a resolution of 150ppi at their final printed size on the poster
Avoid compressed file formats like JPEG
Use RGB mode for color images or Grayscale for B&W images
Images to be imported should be in EPS or TIFF format
Add images to your poster using Insert:Picture:From File…

Avoid adding images by using “cut & paste”

5. Save and submit your file for printing as a PowerPoint presentation (.ppt file).

This information was originally posted on the now defunct UCLA Photographic Services Website.

Submitted by George Helfand george@lunaimaging.com, formerly with UCLA Photographic 

Services.

mailto:george@lunaimaging.com


Microsoft is now offering OneNote for OS X 10.9 as a free download—

Office Blogs, http://blogs.office.com/2014/03/17/onenote-now-on-mac-free-

everywhere-and-service-powered/

Early thoughts—

http://arstechnica.com/apple/2014/03/new-free-onenote-for-os-x-is-a-preview-of-the-next-
office-for-mac-apps/
http://www.infoworld.com/d/applications/microsoft-launches-free-onenote-mac-some-pieces-
missing-238516

Should anyone have input on their experiences with the product, feel free to link them here

Microsoft OneNote for OS X

http://blogs.office.com/2014/03/17/onenote-now-on-mac-free-everywhere-and-service-powered/
http://blogs.office.com/2014/03/17/onenote-now-on-mac-free-everywhere-and-service-powered/
http://arstechnica.com/apple/2014/03/new-free-onenote-for-os-x-is-a-preview-of-the-next-office-for-mac-apps/
http://arstechnica.com/apple/2014/03/new-free-onenote-for-os-x-is-a-preview-of-the-next-office-for-mac-apps/
http://www.infoworld.com/d/applications/microsoft-launches-free-onenote-mac-some-pieces-missing-238516
http://www.infoworld.com/d/applications/microsoft-launches-free-onenote-mac-some-pieces-missing-238516


Microsoft Office 2007 has a new “ribbon” to replace conventional menus, and a new Equation
Editor in Microsoft Word.

To use the old Equation Editor 3.0 if you need easier access to advanced functions, per MTU:

https://help.we.mtu.edu/index.php/Equation_Editor_in_Word_2007

The workaround is to continue to use Equation Editor 3.0, instead of the new equation function. To
do this, ignore the equation icon that appears in Word 2007’s ribbon bar under Insert, Symbols,
Equation. Instead, choose Insert, Text, Object, Microsoft Equation 3.0. This will give you the
equation editing interface that is familiar from previous versions. In the general access computing
labs and classrooms, an equation icon has been added to the “Quick Access Toolbar” that appears
in the upper left of the Word 2007 window. This is a shortcut to the old Equation 3.0 function which
is the recommended method of creating and editing equations at this time. 
-——

If you wish to use the old Equation Editor frequently, you can place a button for it in the Quick
Access Toolbar adjacent to the new round Office button. From the same link as above:

Adding a button that opens Equation Editor is a simple two-part process. Step one is recording the
macro, and step two is adding your recorded macro to the Quick Access Toolbar.

1. Recording the Macro:1. Open Word and click on the View Tab2. In the Macros group, click the
Macros button and choose Record Macro3. In the resulting Dialog name your macro EquationEditor
and choose All Documents (Normal.dotm), under Store Macro in4. Click OK to begin recording5.
Click the Insert Tab in Word’s Ribbon6. Click the button labeled Object, located in the Text Group
to open the Insert Object Window.7. Click on Microsoft Equation 3.0 and click OK.8. This will open
Equation editor.9. Click anywhere on the Word document to return to normal display of the Word
Ribbon and then click on the View tab.10. Click on the Macros button and choose Stop

Using Equation Editor in
Word 2007

https://help.we.mtu.edu/index.php/Equation_Editor_in_Word_2007


Recording.11. The Macro has been recorded.2. Adding your recorded macro to Word’s Quick
Access Toolbar: The Quick Access Toolbar located in the upper-left portion of the Word window, is
a customizable toolbar into which you can place buttons for your frequently used commands and
of course, macros.

Adding your newly created macro to the Quick Access Toolbar:

1. Right-click on the Quick Access Toolbar and choose, Customize Quick Access Toolbar… to
open the customization dialog.

2. From the pull-down menu labeled Choose commands from: select Macros.
3. Click once on the macro name Normal.NewMacros.EquationEditor.
4. Click the Add button.
5. Optional: You can click the Modify button to apply an icon of your choice to this button.
6. Click OK.
7. You now have the macro button for Equation Editor located in the Quick Access Toolbar.

Any time you wish to insert an equation at the cursor simply click the button in the Quick
Access Toolbar and Equation Editor will open ready for you to begin typing your equation. 
-——



1. Older versions of PowerPoint cannot rotate imported scans. If you are using an older
PowerPoint version, you’ll need to use image manipulation software to correct any
pictures that are not properly oriented, before attempting to bring them into your
presentation.

2. Open a blank slide in a new or existing PowerPoint presentation. Make sure the Slides 

Sized for choice list (in Page Setup under the File menu) is set to 35mm Slide, if you
want the imported scan to fill the slide area exactly.

3. Drop down the Insert menu in PowerPoint and select Picture:From File. In the resulting
dialog box, navigate to the desired picture-containing directory. Choose a picture file and
click the Insert button.

4. To prevent unwanted cropping, the imported scan must fit within the slide area. Position
the picture by clicking and dragging somewhere within the picture area. Scale the picture
by clicking and dragging on a corner handle. If necessary, you can use PowerPoint’s
zoom tool to view the entire picture without having to scroll.

5. If the imported scan does not fill the slide area, you can change the slide’s background
color using the Format:Background command. Selecting “Black” as the background
color will make the picture appear to float on the projection screen.

This information was originally posted on the now defunct UCLA Photographic Services Website.

Submitted by George Helfand george@lunaimaging.com, formerly with UCLA Photographic 

Services.

How to Import Scans of
35mm Slides into a
PowerPoint Presentation

mailto:george@lunaimaging.com


By default, PowerPoint will automatically adjust the font size of your body text on each slide
depending on the amount of text. This can create inconsistent font sizes for each slide if one
slideâ�™s body text only has a few lines of text and another slideâ�™s body text has much more. To
disable this feature:

1. On the Tools menu, click AutoCorrect Options.
2. Click the AutoFormat As You Type tab.
3. Under Apply as you type, select or clear the AutoFit body text to placeholder check box.

How to disable auto resize
of fonts within body text in
PowerPoint



You can use the Find and Replace in MS Word to replace any characters with a Line Break or other
special characters or properties (i.e. creating a page break, em dash, column break, etc.) by using
the Find and Replace with “Special” function.

…

Microsoft Word has long had the ability to find & replace non-standard and non-displayable
characters:

Special characters you can use with Find and Replace in Word

â�“orâ�“

WD: Control Codes to Use with Find and Replace

MS Word Replacing
Characters with Line Breaks

http://support.microsoft.com/kb/214204
http://support.microsoft.com/kb/95474


“In addition to the features and functions of Excel that make your database useful, you can also
use the database to merge information into Word for large mailings. This means that you will not
have to duplicate information you already have in your Excel database to perform a mail merge.”

http://www.uwec.edu/Help/Word03/MM-withxls.htm

How to merge data from
Microsoft Excel into
Microsoft Word

http://www.uwec.edu/Help/Word03/MM-withxls.htm


In some cases, a previously activated Microsoft Office 2010 installation may lose its activation.

Reapply the MAK does not help as it loses activation immediately thereafter. Querying the Office
2010 activation status confirms it is activated, then activation is loss without explanation.
Conventional methods as described via the Microsoft Technet forum link below do not work.

In this situation, the Office Software Protection Platform Service may have a corrupt tokens.dat
and cache.dat which needs to be removed and the MAK re-entered.

1. Type in services.msc in the search box and stop the service called Office Software 

Protection Platform
2. Go to C:\ProgramData\Microsoft\OfficeSoftwareProtectionPlatform and rename tokens.dat

to tokens.old
3. Go to C:\ProgramData\Microsoft\OfficeSoftwareProtectionPlatform\Cache and rename 

cache.dat to cache.old
4. Restart the computer and open any Office program. You’ll be asked to retype your

product key and then restart again. Again open any Office program and you may have to
type in the key one more time. It will then ask you to activate online and you’re good to
go.

http://helpdeskgeek.com/office-tips/fix-office-2010-cannot-verify-license-error-message/

https://social.technet.microsoft.com/Forums/en-US/f1a1cc72-d835-4d1d-8fa5-0c0d298fe4bc/why-
does-office-software-protection-platform-service-continue-to-run-after-completing-a-
licensing?forum=officesetupdeployprevious

Previously activated Office
2010 constantly loses
activation

http://helpdeskgeek.com/office-tips/fix-office-2010-cannot-verify-license-error-message/
https://social.technet.microsoft.com/Forums/en-US/f1a1cc72-d835-4d1d-8fa5-0c0d298fe4bc/why-does-office-software-protection-platform-service-continue-to-run-after-completing-a-licensing?forum=officesetupdeployprevious
https://social.technet.microsoft.com/Forums/en-US/f1a1cc72-d835-4d1d-8fa5-0c0d298fe4bc/why-does-office-software-protection-platform-service-continue-to-run-after-completing-a-licensing?forum=officesetupdeployprevious
https://social.technet.microsoft.com/Forums/en-US/f1a1cc72-d835-4d1d-8fa5-0c0d298fe4bc/why-does-office-software-protection-platform-service-continue-to-run-after-completing-a-licensing?forum=officesetupdeployprevious


For manual activation of Office 2010 and Windows 7 through the campus KMS server:

http://www.seasnet.ucla.edu/software/software-download/frequently-asked-questions/mcca-
licenses

Office 2010 (and Windows
7) Manual Activation

http://www.seasnet.ucla.edu/software/software-download/frequently-asked-questions/mcca-licenses
http://www.seasnet.ucla.edu/software/software-download/frequently-asked-questions/mcca-licenses


Microsoft PowerPoint sets a large amount of default preferences which may not be in the best long
term interest of user.

To access these settings, open PowerPoint and go to “Tools” > “Options…”. Mac Office users can
go to “PowerPoint” > “Preferences”.

“Allow Fast Saves” – Turn off, per Microsoft. Future versions of MS Office do not have the Fast Save 
option.

“Save Auto-Recover Info Every” – 3 to 5 minutes is recommended.

“Save PowerPoint Files as” – ‘PowerPoint 97-2003 & 95 Presentation’ is recommended to best
facilitate file transfer between users and collaborators.

Similar settings are advised in other Microsoft Office products.

PowerPoint Preferences /
Options

http://office.microsoft.com/en-us/powerpoint/HA011168771033.aspx
http://office.microsoft.com/en-us/powerpoint/HA101492681033.aspx
http://office.microsoft.com/en-us/powerpoint/HA101492681033.aspx


Problem

Pictures added to PowerPoint are added in a non-optimized form. Consequently, large images
added to PowerPoint result in a large file size.

Solution

In Microsoft Office XP/2002/2003, use the “compress pictures” feature. Mac Office does NOT have
this feature (grmph).

Open PowerPoint, go to View (menu) > Toolbars (submenu) > Picture (menu item). On the
resultant toolbar, click the picture icon with four arrows pointing inward. In the “compress
pictures” windows set as needed.

N O T E <<*
Users have been known to keep original images in PowerPoint for later extraction and
insertion into Word for publication documents. Thus, encourage and inform users to plan
accordingly in advance.

More / Related Info:
How to Optimize, Shrink, or Compress Powerpoint Presentations
Reduce the Size of PowerPoint Files
PowerPoint 2002 Tips and Tricks

Shrink PowerPoint Files

http://www.somacon.com/p133.php
http://office.microsoft.com/en-us/powerpoint/HA011168821033.aspx
http://www.microsoft.com/office/previous/xp/tips/powerpoint.asp


One easy way to insert a flash animation into Powerpoint is to install Shyam’s Toolbox. It contains
an easy to use Flash Movie Wizard, and lets you insert flash with a couple of simple mouse clicks.

Shyam’s Toolbox download link and instructions:

http://skp.mvps.org/toolbox/download.htm

Note: Make sure that the security level of Powerpoint is set to Medium or lower, or the toolbox will 

not install.

Inserting a Macromedia
flash animation into a
Powerpoint presentation

http://skp.mvps.org/toolbox/download.htm


By default, Office 2007 saves documents in a new XML format (.docx). Please follow the link below
to download a widget that allows users to convert files straight from the MAC OS X desktop.

DOCX Converter

Have fun!

• • •

For best compatibility across versions of Microsoft Office, it is best to change the default file
format to NOT save as Office XML.

Microsoft’s official converter from pre-MacOffice 2008 versions is Open XML File Format 

Converter for Mac :
http://go.microsoft.com/fwlink/?LinkId=164915

How do I convert a .docx file
on a Mac OS X

http://docx-converter.com/widget/
http://go.microsoft.com/fwlink/?LinkId=164915


1. Launch a command window with elevated privileges.
◦Type cmd in the search bar to locate the command window.
◦Right click on cmd and click Run as administrator from the context menu, or select cmd and hit 
CTRL-SHIFT-ENTER on the keyboard.
◦Click Yes at the User Account Control prompt to open the command window with elevated
privileges.

2. At the command prompt, type

cd \Program Files\Microsoft Office\Office14\

◦If running 32 bit Office 2010 on 64 bit Windows, type

cd \Program Files (x86)\Microsoft Office\Office14\

3. Run this command to manually specify the KMS activation server.

cscript ospp.vbs /sethst:kms.softwarecentral.ucla.edu

4. Run this command to activate Office with the KMS server:

cscript ospp.vbs /act

How do I manually specify a
KMS server to activate MS
Office 2010



You need to open both workbooks (or whatever workbook you want to copy from and to…)

activate the workbook to copy from, select the sheet(s) to copy and 
click on > Edit >Move or Copy Sheet > Create a Copy 
(if you dont click on create a copy… it’ll move it!)
and nominate the workbook to copy to from the pull down menu.

tada!

When does this work?

A user asks “I have 3 sheets on 3 diff seperate files, and I want to consolidate them into one
workbook….”

tada!

In excel, how to I add a an
external sheet to my
current (or new) workbook?



To share an Office 365 calendar with a non-EM user (such as a g.ucla.edu or non-ucla account),
follow these steps:

https://thepracticalsysadmin.com/add-office-365-calendars-to-google-calendar/

Beware! Depending on the platform, you might import the current calendar rather than subscribe
to it.

To subscribe, you want to copy the long url rather than “share” it.

To get a calendar subscription, you need to subscribe as described here.

https://www.imore.com/how-subscribe-calendars-your-iphone-or-ipad

This procedure worked for me using the .ics link (rather than the .html link) on iOS 11.4.1

Sharing Office 365 calendar
with an iOS device

Subscribe to ICS calendar in iOS

https://thepracticalsysadmin.com/add-office-365-calendars-to-google-calendar/
https://www.imore.com/how-subscribe-calendars-your-iphone-or-ipad


Some users have reported issues that documents they could previously edit in Word are no longer
editable.

After checking document security options and finding no security applied that would prevent
editing, it turns out the document had somehow defaulted to opening in Read Mode.

From the ribbon, go to View , then Edit Document .

Once the normal editing tools are restored, the View ribbon will show the usual viewing options on
the left side, which usually comprise: Read Mode, Print Layout, Web Layout, as well as Outline and
Draft.

Reference:
https://social.technet.microsoft.com/Forums/ie/en-US/8666ac8e-000d-4151-a185-
271bc900807c/unable-to-edit-a-word-2016-document-when-loading-an-existing-
document?forum=word

Read mode in Microsoft
Word

https://social.technet.microsoft.com/Forums/ie/en-US/8666ac8e-000d-4151-a185-271bc900807c/unable-to-edit-a-word-2016-document-when-loading-an-existing-document?forum=word
https://social.technet.microsoft.com/Forums/ie/en-US/8666ac8e-000d-4151-a185-271bc900807c/unable-to-edit-a-word-2016-document-when-loading-an-existing-document?forum=word
https://social.technet.microsoft.com/Forums/ie/en-US/8666ac8e-000d-4151-a185-271bc900807c/unable-to-edit-a-word-2016-document-when-loading-an-existing-document?forum=word


To customize the default save location in Microsoft Office. This may be particularly useful in later
versions of Microsoft Office as the default location is often changes from a user’s local Documents
folder (inside My Computer) to Onedrive (Microsoft OneDrive), which may be confusing to users
who do not realize their default save location has changed.

Steps:

1. Open the Office application where you want to change the default save location.
2. Click on Options (usually at bottom-left)
3. Click on Save (left-hand column)
4. In the Save documents section (Word)/Save workbooks section (Excel)/Save

presentations section (PowerPoint), please check the box for Save to Computer by 

default.
5. Verify the Default local file location is set to the user’s preferred location.
6. Hit ok to save your changes.

https://support.centrestack.com/hc/en-us/articles/360034998913-How-to-change-the-default-save-
location-to-a-custom-path-in-Office-365-2016
https://support.microsoft.com/en-us/office/customize-the-save-experience-in-office-786200a7-f5f2-
4d26-a3ae-b78c60dd5d3b

Change the default save
location in Microsoft Office

https://support.centrestack.com/hc/en-us/articles/360034998913-How-to-change-the-default-save-location-to-a-custom-path-in-Office-365-2016
https://support.centrestack.com/hc/en-us/articles/360034998913-How-to-change-the-default-save-location-to-a-custom-path-in-Office-365-2016
https://support.microsoft.com/en-us/office/customize-the-save-experience-in-office-786200a7-f5f2-4d26-a3ae-b78c60dd5d3b
https://support.microsoft.com/en-us/office/customize-the-save-experience-in-office-786200a7-f5f2-4d26-a3ae-b78c60dd5d3b

