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Zotero [zoh-TAIR-oh] is a free, easy-to-use Firefox extension to help you collect, manage, and cite
your research sources.

http://www.zotero.org/

A good quick demo screencast can be found at:

http://www.zotero.org/documentation/screencasts/intro

Works only with Firefox 2.0, but does so on Win, Mac and Linux. In a quick test, I was able to
search the UCLA Library and download a list of citations.

Need to store a copy of the article? One that is linked to the record in Zotero? Follow instructions
here (#2), to sync PDF storage in Zotero to Box. 
http://guides.library.cornell.edu/zotero_to_Box
Use the “default” email in Zotero.

How can I gather research
resources while using
Firefox?

http://www.zotero.org/
http://www.zotero.org/documentation/screencasts/intro
http://guides.library.cornell.edu/zotero_to_Box


Greasemonkey is a Firefox extension that allows user-created Javascripts to tweak Firefox in
various ways. Greasemonkey scripts are like Firefox extensions, but much simpler.

You can download Greasemonkey from its page on Firefox add-ons.

Once you have it installed, go to userscripts.org to find some scripts. There’s no telling what you
might find. To install a script, click on a link to the script’s .js file, and Greasemonkey will detect it
automatically and let you install it.

If you need additional help, visit the official Greasemonkey website.

Greasemonkey and Firefox

https://addons.mozilla.org/firefox/748/
http://userscripts.org/
http://greasemonkey.mozdev.org/


Mozilla has created a page to detect and verify status of plugins:

http://www.mozilla.org/en-US/plugincheck/

Includes Flash player, Shockware, Java, RealPlayer, Silverlight, and others

(Quoting) The Mozilla Plugin Check page is a general tool for keeping web browser plugins up to
date.
Fully supported browsers do the following:

1. Gathers every plugin’s metadata and optionally its live data
2. Check with the Plugin Directory by mime-type
3. Try to match the plugin metadata with information we know about plugins.
4. If there is a match, then check to see if the version is outdated or has a security

vulnerable.

Although the supported top plugins are a healthy portion of the traffic on the internet, we have a
long way to go in terms of covering all plugins.

. .

Additional information about the project:

http://www.mozilla.org/en-US/plugincheck/more_info.html

Firefox Extension Check

http://www.mozilla.org/en-US/plugincheck/
http://www.mozilla.org/en-US/plugincheck/more_info.html


Quick verifier to keep Firefox plugins up-to-date —

http://www.mozilla.com/en-US/plugincheck/

Keeping Firefox Plugins Up-
to-Date

http://www.mozilla.com/en-US/plugincheck/


1Password 3.9.20 add-on for Firefox displays both the “1P” and the 1Password key icon in the
Firefox toolbar in Firefox 29.0.

This is a result of 1Password’s add-on not yet properly supporting Firefox 29’s new UI— Firefox 29
changes extension display behavior.

1. Open Firefox 29
2. Click on the hamburger button in the upper-right corner
3. Click on “Customize” in the lower-left corner of the popup window
4. On the toolbar, you should see the following text: “Show 1Password” (no quotes)
5. Right-click on “Show 1Password”, then click on: “Remove from Toolbar”
6. Click on the green button labelled “Exit Customize”

http://discussions.agilebits.com/discussion/24332/firefox-29-0-1password-extension-buttons

1Password icon displaying
twice in Firefox 29

http://discussions.agilebits.com/discussion/24332/firefox-29-0-1password-extension-buttons


I just tried printing my stub from Firefox, it pulled up Acrobat Reader, so I’m assuming it’ll print
fine.

Despite personal and security perferences, users may need to use Internet Explorer ocassionally to
get full functionality on certain websites.

Why can't I print my UCLA
paystub from Firefox?



Taken from: 
http://cybercapital.org/index.php/2007/05/21/did-you-know-these-basic-firefox-tips/

1. To quickly find any word in a web page type /word it will highlight the word and press
Ctrl+G to â�œFind Againâ�� that word again

2. If you wish to remove an item from your Address Bar Drop down menu,
Highlight it without clicking and use Shift+Delete.

3. Clear your Download history to make the download manager more
responsive : Tools | Options | Privacy

4. Type about:cache?device=disk in your address bar to view/save items
that you have in your firefox disk cache

5. Type about:cache?device=memory in your address bar to view/save items
that you have in your Firefox memory cache

6. Drag any link to the Download Manager Window to add & download the
link.

7. If you accidentally delete a bookmark and want to recover it, open the
â�œBookmarks Managerâ�� and use Ctrl+Z,
or Edit | Undo.

8. Double Clicking empty space on the Tab Bar will open a â�˜New Tabâ�™
9. Holding down the Ctrl key when you right click

to â�œView Imageâ�� or â�œView Background Imageâ�� will open the image in a New
Tab or New Window.

10. A bookmarks Folderâ�™s position can also be Dragged & Dropped but you must hold down
the SHIFT key while Dragging.

11. To prevent a website from replacing/changing your rightclick context
menu go to Tools > Options > Web Features then click the â�œadvanced
tabâ�� and de-select â�œremove or replace context menusâ��. Update: go to
Tools>Options>content>Advanced on Firefox2

Did you know these basic
Firefox Tips?

http://cybercapital.org/index.php/2007/05/21/did-you-know-these-basic-firefox-tips/


12. You can work offline in Firefox just go to File > Work Offline. This
means that you can browse your previously visited pages even when
youâ�™re offline this is a really cool feature but not many people who use it.

13. You can bookmark the current page by dragging the icon from the
location bar to your Bookmarks folder. You can also drag it to the
desktop to make an icon for that page.

14. To stop animated gifs from moving, press the ESC key.



Firefox keeps a per profile dictionary of custom words. To correct words which inadvertently enter
it:

Go to “%APPDATA%\Mozilla\Firefox\Profiles”
On Mac OS X, go to “~/Library/Application Support/Firefox/Profiles”
Enter the profile folder, usually like “.default”
Edit “persdict.dat” with a text editor (WordPad, Notepad, or Textedit)

Save, and done.

Edit Mispelled Words in
Firefox



The Popup Blocker Options/Preferences are located in the Content panel of
Tools > OptionsEdit > PreferencesFirefox > Preferences.

From there, you can do the following things:

Block Popup Windows: Deselect this option preference to
disable the popup blocker altogether.

Exceptions dialog: This is a list of sites that you want to allow
to display popups. The dialog has the following choices:

o Allow: Click this to add a web site to the exceptions list.o Remove Site: Click this to remove a
web site from the exceptions list.o Remove All Sites: Click this to remove all of the web sites inthe
exceptions list.
Note: Blocking popups may not always work and may interfere with
some web sites.

How do I control the popup
blocker settings in Firefox?



In addition to keeping information on all your downloads in one place, the
Download Manager keeps convenient download actions easily accessible for each
of your downloads.

Pause

You can pause any downloads currently in progress by clicking thePause link beside the file entry.
This may be useful, forexample, if you need to open a small download started after a large
download.Pausing downloads gives you the choice to decide which of your downloads aremost
important. When you want to continue downloading those files, simply usethe Resume link to
finish those downloads.
Cancel

If after starting a download you decide you no longer need that file, cancelingthe download is
simple: just use the Cancel link beside that fileentry to cancel it and free up your connection for
your browsing and otherdownloads.
Open the File

When a download has finished, the Open link will appearby the file entry. Use it to open the file.
Remove the File’s Entry

If you do not wish to store information on a particular download, removing theentry is as simple as
the click of a mouse. Simply use the Removelink beside the file entry to delete it.
Retry a Download

If for any reason a download does not complete, it is easy to attempt thedownload again. To
recover from a failed download and retry it, just use theRetry link next to the file entry and Firefox

What can I do with the
Download Manager on
Firefox?



willrestart the download for you.
Show Download Folder

If you have set Firefox to save all downloads to a folder inDownload Manager
OptionsPreferences,you can open this folder by clicking the Folder Name at thebottom of the
Download Manager window. 



There are two basic methods of customizing the toolbars in
Firefox:

Adding/Removing Toolbars

Rearranging Items on the
Toolbars

Adding/Removing Toolbars

You can take away certain toolbars if you do not wish to keep them on your
screen. Currently, these toolbars can be removed:

Navigation Toolbar

Bookmarks Toolbar

You cannot currently remove the Menu Bar because you cannot move the menu
items (File, Edit, Help, etc.) to a different toolbar, and they must stay on
the screen at all times.

To remove a toolbar, look in the View menu on your Menu Bar. Select View > Toolbars. You should
see a few menu items.
The top ones (above the separator) are the toolbars you may show. Toolbars
currently shown are checked, and toolbars currently hidden are not checked.
To show or hide a toolbar, simply click its menu item. The toolbar will now
be shown or hidden based on your choice.

To add a toolbar, select View > Toolbars >
Customize. Click on Add New Toolbar (in the bottom of the

How do I customize the
toolbars in Firefox?



dialog). This should give you a dialog to enter a name. Enter a name, click
OK, and then click Done. Now select the View > Toolbars menu, and you should see your new
toolbar listed. Follow the procedures in the previous section to show or hide
it.

Rearranging Toolbar Items

To rearrange the items (icons, buttons, text boxes, etc.) on your toolbar,
right-clickpress Ctrl and
click on any part of the toolbar that is not a text box and select
Customize…. This will bring up the toolbar
customization dialog.

Drag and drop any items you want to and from the toolbars (excluding the
menu items). You can also rearrange icons already on the toolbars by
dragging and dropping them wherever you wish. When the toolbars and items are
arranged the way you want them, click Done.

Special Toolbar Items

There are a few special items that are available to you when customizing the
toolbar. They are as follows:

Separators: These allow you to separate items on the
toolbars with a small vertical line.

Spacers: These allow you to separate items on the
toolbars with a fixed-size space, usually around 20 pixels on most
themes.

Flexible spacers: Spacers allow you to separate items
on the toolbars with a space. These spacers automatically resize to fill
all of the empty space on the toolbar. These are good for positioning
items on the right of a toolbar.

Themes



Themes are small files that are installed in Firefox that change
the look and feel of Firefox. Themes are not allowed to modify the
actions or functionality of Firefox, only the look.

Getting and Installing Themes

You can download and install many themes from Mozilla Update.
Internet searches will find many other themes as well.

Usually when you click on a link to install a theme, Firefox
displays a dialog asking you for permission to install the theme. You can
choose to allow the download and installation or to cancel the process.

Uninstalling Themes

Should you ever wish to remove a theme from Firefox, select Tools > Themes to open the Theme
Manager.

In the Theme Manager, select the theme you wish to remove, and click the
Uninstall button. You may need to close and then reopen
Firefox for all changes to take effect.

Switching Themes

To switch between your installed themes, select Tools
> Themes to open the Theme Manager.

In the Theme Manager, select the theme of your choice, and click
the Use Theme button. It is recommended that you close and then
reopen Firefox so that the theme can be applied correctly.

Updating Themes

Whenever you would like to check for a newer version of a theme that you
have installed, select Tools > Themes to open
the Theme Manager.

In the Theme Manager, Firefox displays Update Now buttons



for themes with available updates. Click the respective button for the theme
you would like to update.

By default, Firefox will periodically check and notify you when a
new version for one of your installed themes is available. You can change
this behavior in the Update
tab of the Advanced panel of OptionsPreferences.
You can check for updates manually by clicking the Find Updates
button.

Extensions

Extensions are small add-ons to Firefox that change existing
browser functionality or add new functionality.

Getting and Installing Extensions

Installing an extension involves a very similar process to installing
themes. Extensions can be found at Mozilla Update.

There should be an install link for each extension on that extension’s
page. As long as JavaScript is not disabled in your browser, clicking this
link will install the extension for you.

Uninstalling Extensions

Should you ever wish to remove an extension from Firefox, select
Tools > Extensions to open the Extension
Manager.

In the Extension Manager, select the extension you wish to remove, and click
the Uninstall button. You may need to close and then reopen
Firefox for all changes to take effect.

Updating Extensions

Whenever you would like to check for a newer version of an extension that
you have installed, select Tools >



Extensions to open the Extension Manager.

In the Extension Manager, Firefox displays Update Now
buttons for extensions with available updates. Click the respective button for
the extension you would like to update.

By default, Firefox will periodically check and notify you when a
new version for one of your installed extensions is available. You can change
this behavior in the Update
tab of the Advanced panel of OptionsPreferences.
You can check for updates manually by clicking the Find Updates
button.



This is a list of the most common mouse shortcuts in Mozilla Firefox.
-———————————————-
Back

Ctrl+Shift+Scroll Down

Close TabMiddle-click on Tab

Decrease Text SizeCtrlCmd+Scroll up

ForwardCtrl+Sift+Scroll up

Increase Text SizeCtrlCmd+Scroll down

New TabDouble-Click on Tab Bar

Open in Background TabCtrlCmd+Left-clickMiddle-click

Open in Foreground TabCtrlCmd+Shift+Left-clickShift+Middle-click

Open in New WindowShift+Left-click

Paste URL and GoMiddle-click on Tab

Reload (override cache)
Shift+Reload button
-———————————————- 
Save Page As

What are the most common
mouse shortcuts for Mozilla
Firefox?



AltOpt+Left-click

Scroll line by lineAltOpt+Scroll 



Printing a Page

To print the current page:

Select File > Print.

To print selected text:

Select the text in the current page.

Select File > Print. The print dialog
box will appear.

Under Print Range, click Selection.

The web page’s author and the size of the printed page, not the size of the
onscreen window, determine placement of content on the printed page. Text is
wrapped and graphics are repositioned to accommodate paper size.

How do I print from Firefox?



To customize how pages are printed in Firefox, you can use Page Setup:

Select File > Page Setup.

In Page Setup, you can change the following settings for pages you want to
print:

Format & Options: Choose the orientation, scale, and other
options:

o Orientation:+ Portrait: Choose this to position the pagenormally, with the shorter side facing
up.+ Landscape: Choose this to position the pagesideways, with the longer side facing up.o Scale:
Type in a percentage of the original size. For example,type “50” to make each page half the size
of the original page.+ Shrink To Fit Page Width: Select this to automaticallyresize the page to the
width of the paper.o Options:+ Print Background (colors and images): Select this toprint
background images and colors. If unselected only pictures andcolor in the foreground (in front) are
printed.

Margins & Header/Footer: Click this tab to set up margins,headers, and footers:

o Margins:+ Top, Bottom, Left, Right: Type a margin in the given unitsfor the top, bottom, left, and
right margins.o Headers & Footers: Each drop-down list represents eithera header or a footer area.
The top row of drop-down lists are for theleft,center, and right header areas. The bottom row are
for the left, center,and right footer areas. In each drop-down list, choose one of the
followingoptions:+ -blank-: Show nothing in this area.+ Title: Show the web page title.+ URL: Show
the web page URL (URL’s usually start with“http://”).+ Date/Time: Show the date and time when
the web page isprinted.+ Page #: Show the page number of each page.+ Page # of #: Show the
page number along with the total numberof pages. For example, if you print a five page web page,
“3 of 5”would be shown on the third page.+ Custom: Type your own text. You can include any of
thefollowing codes to print specific information:

How do I use Page Setup on
Firefox?

http://


1. &PT: Page Number with Total (Example: “3 of
5”)

1. &P: Page Number

1. &D: Date

1. &U: URL

1. &T: Page Title



To make Firefox your default web browser:

1. Select Tools > OptionsEdit > PreferencesFirefox > Preferences and click the “Check Now”
button in the General panel.
…

When setting a computer to use Firefox as the primary browser, it is helpful to disable Internet
Explorer’s checks to make it the default browser:

Start > Settings > Control Panels > Internet Options > Programs > Internet Explorer should check
to see whether it is the default browser

On campus, some sites are not browser neutral and require Internet Explorer. To facilitate using IE
with Firefox, check the Firefox plug-ins IE Tab or IE View

How do I make Firefox my
default browser?

https://addons.mozilla.org/firefox/1419/
https://addons.mozilla.org/firefox/35/


Getting and Installing Themes
-—————————————

You can download and install many themes from Mozilla Update.
Internet searches will find many other themes as well.

Usually when you click on a link to install a theme, Firefox
displays a dialog asking you for permission to install the theme. You can
choose to allow the download and installation or to cancel the process.

Uninstalling Themes
-————————

Should you ever wish to remove a theme from Firefox, select Tools > Themes to open the Theme
Manager.

In the Theme Manager, select the theme you wish to remove, and click the
Uninstall button. You may need to close and then reopen
Firefox for all changes to take effect.

Switching Themes
-——————-

To switch between your installed themes, select Tools
> Themes to open the Theme Manager.

In the Theme Manager, select the theme of your choice, and click

How do I
get/install/uninstall/switch/update
themes in Firefox?



the Use Theme button. It is recommended that you close and then
reopen Firefox so that the theme can be applied correctly.

Updating Themes
-——————

Whenever you would like to check for a newer version of a theme that you
have installed, select Tools > Themes to open
the Theme Manager.

In the Theme Manager, Firefox displays Update Now buttons
for themes with available updates. Click the respective button for the theme
you would like to update.

By default, Firefox will periodically check and notify you when a
new version for one of your installed themes is available. You can change
this behavior in the Update
tab of the Advanced panel of OptionsPreferences.
You can check for updates manually by clicking the Find Updates
button.



Mozilla offers an Extended Support Release (ESR) based on an official release of Firefox for
desktop for use by organizations including schools, universities, businesses and others who need
extended support for mass deployments―

https://www.mozilla.org/en-US/firefox/organizations/faq/
https://wiki.mozilla.org/Enterprise/Firefox/ExtendedSupport:Proposal
Downloads, http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-esr/
Wikipedia, http://en.wikipedia.org/wiki/History_of_Firefox#Extended_Support_Release

Firefox ESR

https://www.mozilla.org/en-US/firefox/organizations/faq/
https://wiki.mozilla.org/Enterprise/Firefox/ExtendedSupport:Proposal
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-esr/
http://en.wikipedia.org/wiki/History_of_Firefox#Extended_Support_Release


Firefox 43.0.1 introduced a new "visit: suggestion at the top of the list of sites returned in searches
entered into the address bar.

To disable this (standard behavior prior to 43.0.1):

1. Go to about:config
2. Change browser.urlbar.unifiedcomplete to false

To enable this (standard behavior in 43.0.1):

1. Go to about:config
2. Change browser.urlbar.unifiedcomplete to true

Disabled (default prior to 43.0.1):

Adjust Firefox top visit
suggestion in address bar



Enabled (default as of 43.0.1):

Source:
https://www.reddit.com/r/firefox/comments/3×98fa/is_there_a_way_of_turning_off_the_top_visit/

https://www.reddit.com/r/firefox/comments/3×98fa/is_there_a_way_of_turning_off_the_top_visit/


Here’s another cool add-on

http://www.getfirebug.com/

firebug is similar to the “web developer” firefox plugin but amped up.

And another http://developer.yahoo.com/yslow/

more on yslow here
http://www.phpied.com/yslow-performance-extension-for-firebug/

Firefox Add-on’s are small extensions that add new functionality to Mozilla Firefox. They can add
new features, toolbars, and are completely customizable.

It is in a developers interest to peruse Firefox’s “Developer Tools” and “Website Integration” add-
on categories to find extensions which fit your work style: https://addons.mozilla.org/firefox/

—

TO INSTALL: Click the link, wait a moment until you can click the “Install Now” button that pops up,
wait for it to download, and restart your browser.

TO REMOVE: If it’s a toolbar, you can hide them under View > Toolbars, un-checking (selecting)
Web Developer, for example. To remove it all together, select Tools > Extensions, selecting the
extension and pressing Uninstall on the bottom left.

Colorzilla – Advanced Eyedropper, ColorPicker, Page Zoomer, and other goodies. (Windows
Only)

HTML Validator – Tidy for FireFox! Highly recommended for web developers. Lets you check

Firefox Add-Ons for Web
Developers

http://www.getfirebug.com/
http://developer.yahoo.com/yslow/
http://www.phpied.com/yslow-performance-extension-for-firebug/
https://addons.mozilla.org/firefox/
http://www.iosart.com/firefox/colorzilla/
http://users.skynet.be/mgueury/mozilla/


your page’s validation by doing a View / Page Source.

FireBug – Allows live HTML, CSS, and JavaScript edits and lets you visualize CSS metrics. 
MUST HAVE for debugging and web developing. Apparently it’s also good for viewing and 
debugging Ajax traffic.

MeasureIt – Provides a ruler to measure the width and height (in pixels) of any element on a
webpage.

View Formatted Source – Displays CSS being applied to each element. Great for debugging.

View Source Chart – Tame tables and containers. Great for debugging.

IE Tab and/or IE View add-ons to emulate IE functionality in Firefox. More on IE Tab here.

Copy Plain Text – Allows you to copy plain text into editors directly from a webpage without
having to go through notepad etc.

Load Time Analyzer – Allows developers to measure and graph how long web pages take to
load in Firefox.

Web Developer (see below)

Web Developer – For web developers and programmers. Useful functions include:

1. Disable > Disable JavaScript. This can reveal what we deliver, or don’t, for the 1.5% who have
JavaScript off.
2. Cookies. If your UCLA site uses cookies, you can see how it breaks down if cookies are turned off.
3. CSS. To have a truly accessible site, turning off the CSS should show a fairly logical structure. Or
not.
4. Resize. You can check how it looks at 800×600 even if your monitor has a larger resolution, and
how your site fits for the < 10% who stick with the smaller resolution.
5. Tools. Something to consider for setting a standard: valid HTML, CSS, feeds, and Section 508/
WAI accessibility. This is a tedious process, on a programming end, but it’s a professional step to
make it check out with web accessibility standards — a step beyond if it just “works” in IE/Firefox.

http://www.getfirebug.com/
http://www.ddj.com/dept/debug/196802787
http://www.ddj.com/dept/debug/196802787
https://addons.mozilla.org/extensions/moreinfo.php?id=539
https://addons.mozilla.org/firefox/697/
https://addons.mozilla.org/firefox/655/
https://addons.mozilla.org/firefox/1419/
https://addons.mozilla.org/firefox/35/
http://mi6.ais.ucla.edu/devbriefs/ie-tab-extension-for-firefox
https://addons.mozilla.org/extensions/moreinfo.php?id=134
https://addons.mozilla.org/firefox/3371/
https://addons.mozilla.org/firefox/60/


See also, https://kb.ucla.edu/link/220

https://kb.ucla.edu/link/220


Firefox is pushing tab groups to better organize the web browsing experience. Video & web page
gives a overview:

http://support.mozilla.com/en-US/kb/what-are-tab-groups

Firefox Tab Groups

http://support.mozilla.com/en-US/kb/what-are-tab-groups


Firefox’s major asset is its wide variety of user community created and supported extensions.

The ability the save all open windows and active tabs was a “cannot live without” feature brought
forth, in part by Tab Mix Plus. Firefox 2 now incorporates similar functionality. The ability to
sync bookmarks across various installs using the Foxmarks extension greatly eased the transition
between desktop, laptop, and/or virtual machines as well.

Google, being Google, has upped the ante with “Google Browser Sync for Firefox ":

https://addons.mozilla.org/addon.php?id=1122. (Verbatim) Google Browser Sync for Firefox
is an extension that continuously synchronizes your browser settings—including bookmarks,
history, persistent cookies, and saved passwords—across your computers. It also allows you to
restore open tabs and windows across different machines and browser sessions.

A valuable extension to save session feature between computers, such as those users who use a
desktop and laptop, or Windows machine and Mac OS machine.

Session Manager allowed for more powerful session saving than Tab Mix Plus, not only loading
whatever sites you were visiting but the position of the scrollbar, contents typed into textfields,
etc. At the moment this extension is not available for Firefox 2.0

Google Browser Sync!

https://addons.mozilla.org/addon.php?id=1122
https://addons.mozilla.org/firefox/2410/
https://addons.mozilla.org/addon.php?id=1122
https://addons.mozilla.org/firefox/2324/


In case you come across any users who might be running v7.x of Firefox on Win x86 or x64, and
complain of slow performance, can’t/won’t load pages, etc., while other browsers have no
problem, below is an Mozilla article which may help.

“If you have a problem connecting to a website, you may see error messages like Server Not 

Found. This article describes how to troubleshoot problems that cause this error” —

http://support.mozilla.com/en-US/kb/Server%20not%20found

See also,

http://support.mozilla.com/en-US/kb/Error%20loading%20web%20sites

Firefox 7 and Internet
Connection Issues

http://support.mozilla.com/en-US/kb/Server not found
http://support.mozilla.com/en-US/kb/Error loading web sites


Internet Explorer 7 (IE7) for Windows XP+ only has been released in November 2006. Some have
said the “Quick Tabs” is reason alone to use IE7.

Firefox already has had such a feature through add-ons:

Tab Catalog — https://addons.mozilla.org/firefox/1937/

Has an option to disable the viewing of the tab catalog on button roll-over. The Tab Catalog
button is a well-behaved toolbar element and can be placed where desired on the toolbar(s).

Firefox Showcase — https://addons.mozilla.org/firefox/1810/

Very much like Quick Tabs.

Viamatic foXpose — https://addons.mozilla.org/firefox/1457/

Also, very much like Quick Tabs.

Ctrl Tab Preview — https://addons.mozilla.org/firefox/2134/

A bit different. Has a very Mac OS X feel to it.

As with most Firefox extensions, many options are available for a given extension/add-on.

It has been said, “If you are not using Firefox extensions, you are not using Firefox”.

"Quick Tabs" in Firefox

https://addons.mozilla.org/firefox/1937/
https://addons.mozilla.org/firefox/1937/
https://addons.mozilla.org/firefox/1810/
https://addons.mozilla.org/firefox/1810/
https://addons.mozilla.org/firefox/1457/
https://addons.mozilla.org/firefox/1457/
https://addons.mozilla.org/firefox/2134/
https://addons.mozilla.org/firefox/2134/


Taken from a PC World article…

Open Firefox

Type about:config in address bar and press Enter

Type network.http in the filter field

Double-click network.http.pipelining.maxrequests to bring up the "Enter integer value’ dialog box.
Enter a higher number than the default 4: try 15. and click OK.

Double-click network.http.proxy.pipelining to set it to ‘true’.

Right-click anywhere on the page and select New Integer. Enter nglayout.initialpaint.delay and
then click OK.

Set the integer value to 0 (zero) and click OK again.

Optimizing Firefox for
broadband


